Switching from Gaim to Pidgin

PidginIt has now been for a while that Gaim has changed its name to Pidgin (no, it is not pigeon…) due to a lawsuit with AOL and published the version 2 of this instant messenger. Now they have released 2.0.1, so I decided to install this new version.
My Ubuntu did not automatically install the new version. Unfortunately I could not find a .deb-package for Pidgin, so I had to compile Pidgin myself. Before doing that I made a backup of my folder ~/.gaim containing my preferences.

First, I had to download the source and then unpack the .tar.bz2-file using the command tar -xjf pidgin-2.0.1.tar.bz2. After a cd pidgin-2.0.1, I executed the first of the classic three commands to compile a program: ./configure. Unfortunately I got the message You must have libxml2 >= 2.6.0 development headers installed to build. so that I had to install sudo apt-get install libxml2-dev before again executing ./configure. This time everything went well and I was told configure complete, now type ‹make›. Obviously I followed this advise and typed make which busied my aging computer for a couple of minutes. To finalize the installation I had to type make install. After that, everything was ok.
I can now start Pidgin by typing pidgin in the terminal or by using the entry in the menu (Network -> Pidgin Instant Messenger).

Pidgin does not seem to have changed a lot compared to the beta version of Gaim 2 that I had installed before (however it has changed a lot compared to the older versions). The design and icons are different and more modern, but the functionalities are about the same. Unfortunately it does not support video or voice chats, but personally I prefer writing over talking, so this missing feature does not really disturb me. What I really appreciate is that Pidgin supports no less than 15 different protocols. As an example, I use it for my ICQ, MSN and GoogleTalk accounts.

Some more possible errors when executing ./configure
If you get the error You must have the GLib 2.0 development headers installed to build. you will have to execute the command sudo apt-get install libglib2.0-dev

If you get the error You must have the GTK+ 2.0 development headers installed to compile Pidgin. type sudo apt-get install libgtk2.0-dev. This will install a whole bunch of programs.

7 thoughts on “Switching from Gaim to Pidgin

  1. Hola Dominik

    .deb packages for pidgin on ubuntu you can find on getdeb.net

    Linux Beginners working with Ubuntu should try the .deb packages. it is far easyier than compiling yourself…

  2. Hi Manfred,

    That’s true, .deb is more comfortable. But at the time I installed pidgin I could not find any .deb-files.

    For beginners: to install such a .deb-file you have to execute the command ‹dpkg -i yourpackage›

  3. Chris

    Hi Dude. This was great just what I needed (great instructions) as like a few I’m new to Linux but pass on MS 🙂

  4. PewterHydra

    I just wanted to say thanks. My pidgin install got caught on «You must have the GTK+ 2.0 development headers» and I wasn’t sure how to safely update gtk. Following your instruction I now have it working, so…


  5. If you want to hear a reader’s feedback 🙂 , I rate this post for four from five. Detailed info, but I just have to go to that damn google to find the missed pieces. Thanks, anyway!

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.